LOW 2.1 NVD
CVE-2026-120597
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file cla
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
References
- https://github.com/bevennyamande/welcart-poc
- https://vuldb.com/cve/CVE-2026-120597
- https://vuldb.com/submit/1039186
- https://vuldb.com/vuln/429933
- https://vuldb.com/vuln/429933/cti
This low severity vulnerability with a CVSS score of 2.1 was published on 2026-11-02 via NVD.
vulnfeed aggregates 17711 vulnerabilities from NVD, CISA KEV,
Ubuntu, Debian, Red Hat, Kubernetes, Exploit-DB, OSS-Security, GitHub and OpenStack — updated every 4 hours.